错误SQL 查询:/*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;MySQL 返回:#1065 - Query was empty 错误原因:由于4n版本的数据库编码为latin1,5n版本的数据库编码为utf8.导致。解决办法:去掉如下代码/*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;/*!40101 SET...
Read More >
第33页
错误SQL 查询:/*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;MySQL 返回:#1065 - Query was empty 错误原因:由于4n版本的数据库编码为latin1,5n版本的数据库编码为utf8.导致。解决办法:去掉如下代码/*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;/*!40101 SET...
Read More >
2012
12-31
12-31
24时区,GMT,UTC,DST,CST时间详解 NEW
全球24个时区的划分 相较于两地时间表,可以显示世界各时区时间和地名的世界时区表(World Time),就显得精密与复杂多了,通常世界时区表的表盘上会标示着全球24个时区的城市名称,但究竟这24个时区是如何产生的?过去世界各地原本各自订定当地时间,但随着交通和电讯的发达,各地交流日益频繁,不同的地方时间,造成许多困扰,于是在西元1884年的国际会议上制定了全球性的标准时,明定以英国伦敦格林威治这个地方为零度经线的起点(亦称为本初子午线),并以地球由西向东每24小时...
Read More >
2012
12-31
12-31
IE下验证码一直错误,火狐正确(IE和Firefox下的Cookie兼容问题) NEW
网站在别人服务器登陆正常,迁移到自己的测试服务器后,IE,360等基于ie内核的浏览器无法登陆(一直提示验证码输入错误,实际输入时正确的),火狐可以正常登陆。突然出现这种奇怪的问题,很是纠结。通过查看代码,逻辑很清晰,代码不应该有问题。跟踪浏览器信息,发现登陆逻辑正常执行,最后进行了页面跳转,之后又跳转回来(即又刷新了一次,又回到登陆页面),那么应该是权限验证失败。没有抛出无权限提示,那么只能是读取Cookie失败。检查IE的Cookie记录,发现登陆页面没有完成Cookie...
Read More >
2012
12-31
12-31
sql批量替换字段里指定的字符串语法
语法:update 表名 set 字段名=replace(字段名,'要替换的字符串','要替换成的字符串');例如:把字段里的aaaaxxxbbb 变成 ccccxxxbbbupdate 表名 set 字段名=replace(字段名,'aaaa','cccc');...
Read More >
Linux下phpMyAdmin出现Wrong permissions on configuration file, should not be world writable!错误解决办法:phpMyAdmin自身设置777权限不行,为了安全phpmyadmin在linux下只能以755的权限才能正确运行,要把所有文件的组和其他用户的写权限全部去掉才行,将权限改为755cd到phpMyAdmin目录,设置文件夹权限为755命令为:chmod -R 755 phpMyAdmin...
Read More >
2012
12-17
12-17
linux下安装和使用花生壳
以redhat系列为例:一、安装说明(以CentOS 5为例) 1、安装必要的开发包 [root@localhost ~]# yum install gcc gcc-c++ autoconf automake 2、下载phddns-2.0.2.16556.tar.gz到某一个目录 [root@localhost ~]# wget http://download.oray.com/peanuthull/phddns-2.0.2.16556.tar.gz www.xxx.com...
Read More >
2012
12-17
12-17
错误信息:ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)
linux下mysql服务错误错误信息:ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)错误原因:由于mysql 默认的mysql.sock 是在/var/lib/mysql/mysql.sock,但linux系统总是去/tmp/mysql.sock查找,所以会报错解决办法:1.直接指定mysql通道:[root@localhost ~]#...
Read More >
2012
12-17
12-17
Linux下apache和MySQL的启动与停止
Linux下apache和MySQL的启动与停止一、启动方式(1)apache假如安装目录为:/usr/local/apache2脚本启动 /usr/local/apache2/bin/apachectl start(2)mysql先查看状态:# /etc/rc.d/init.d/mysql status如果显示[FAILED]说明是停止的1、使用 service 启动:service mysqld start2、使用 mysqld 脚本启动:/etc/rc.d/inint....
Read More >
2012
12-15
12-15
centos下 Apache、php、mysql默认安装路径
apache:如果采用RPM包安装,安装路径应在 /etc/httpd目录下apache配置文件:/etc/httpd/conf/httpd.confApache模块路径:/usr/sbin/apachectlweb目录:/var/www/html如果采用源代码安装,一般默认安装在/usr/local/apache2目录下php:如果采用RPM包安装,安装路径应在 /etc/目录下php的配置文件:/etc/php.ini如果采用源代码安装,一般默认安装在/usr/local...
Read More >
2012
12-08
12-08
PHP定时执行代码
<?php ignore_user_abort();//关掉浏览器,PHP脚本也可以继续执行. set_time_limit(3000);// 通过set_time_limit(0)可以让程序无限制的执行下去 $interval=5;// 每隔5s运行 //方法1--死循环 do{ echo '测试'.time().''; sleep($interval);// 等待5s }while(true); //方法2---sleep 定时执行...
Read More >